Вопрос по информатике:
Дано целое число N(>1).Найдите наибольшее целое число K ,ПРИ КОТОРОМ ВЫПОЛНЯЛОСЬ неравенство 3 в степени К<N
Иходные данные N=65
Пример верного решения K=4
- 16.08.2018 03:58
- Информатика
- remove_red_eye 16274
- thumb_up 95
Ответы и объяснения 1
Var n,i,k,j:integer;
begin
readln(n);
i:=1;
j:=3;
while n>i do begin
i:=i*j;
k:=k+1;
end;
writeln(k-1);
end.
- 16.08.2018 22:20
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.