Вопрос по информатике:
1)Проверка условия и ветвление в алгоритме.Напишите программу которая анализирует введённое с клавиатуры число и выдает на экран: а)удвоенное значение числа,если число положительное; б)абсолютное значение числа,если число отрицательное.
2)Напишите программу которая анализирует введенное с клавиатуры число на четность и сообщает о результате.
- 17.08.2016 22:18
- Информатика
- remove_red_eye 10293
- thumb_up 39
Ответы и объяснения 1
1)
Var x:integer;
Begin
write('x=');
readln(x);
if x>=0 then x:=x*2;
else x:=abs(x);
writeln('Otvet=',x);
readln;
End.
- 19.08.2016 21:44
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.