Вопрос по информатике:
1)Составить программу нахождения наибольшего общего делителя НОД. Составить блок-схему
2)Составить программу решения примера
1+2+4+6+8..
- 17.10.2017 13:08
- Информатика
- remove_red_eye 11091
- thumb_up 95
Ответы и объяснения 1
Program pr1;
var x,y, nod:integer;
begin
readln(x,y);
repeat
if x > y then x:=x mod y
else y:=y mod x
until x*y=0;
nod:=x+y;
writeln('НОД=', nod);
end.
program pr2;
var i,n,sum:integer;
begin
readln(n);
sum:=1;
for i:=1 to n do
if i mod 2 = 0 then inc(sum,i);
writeln(sum);
end.
- 18.10.2017 05:22
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.