Вопрос по информатике:
Pascal
Выведите все числа на отрезке от a до b, являющиеся полными квадратами.
Примеры:
Входные данные
1
5
Выходные данные
1 4
- 14.02.2018 02:14
- Информатика
- remove_red_eye 9186
- thumb_up 97
Ответы и объяснения 1
Var a,b,i:integer;
x:real;
Begin
Readln(a);
Readln(b);
If a<0 Then a:=1;
For i:=a to b do
Begin
x:=sqrt(i);
If frac(x)=0 Then Write(i,' ');
End;
End.
- 15.02.2018 06:51
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.