Вопрос по информатике:
Составить программу в СИ:
1) Составить программу, проверяющую, является ли заданное натуральное число совершенным, то есть равным сумме своих положительных делителей, кроме самого этого числа.
2) Напечатать числа в виде следующей таблицы:
5 5 5 5 5
6 6 6 6
7 7 7
8 8
9
- 05.03.2018 11:09
- Информатика
- remove_red_eye 17887
- thumb_up 57
Ответы и объяснения 1
1)
#include
#include
int sover (int n)
{
int sum = 0;
for (int i = 1; i<=n/2; i++)
if (n%i==0) sum+=i;
if (sum==n)
return 1;
else return 0;
}
int main()
{
int n;
printf ("N = ");br /> scanf (""%d"",&n
- 06.03.2018 09:11
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.