Вопрос по информатике:
Написать программу, Паскаль. Дано натуральное число N. Вычислить S = 1! + 2! +3! + ... + n! (n>=1) Решить через repeat (с постусловием)
- 09.08.2015 01:10
- Информатика
- remove_red_eye 17450
- thumb_up 6
Ответы и объяснения 1
Var S,f:longint; n,a:byte;
begin
s:=0;a:=1;f:=1;
readln(n);
repeat
f:=f*a;
s:=s+f;
inc(a);
until a>n;
writeln(s);
end.
Вроде так
- 09.08.2015 04:18
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.