Вопрос по информатике:
Вы ввели трехзначное число. Затем ввели любую цифру. Составьте программу, определяющую, есть ли в этом числе данная цифра. И объясните...
- 21.11.2017 21:36
- Информатика
- remove_red_eye 903
- thumb_up 71
Ответы и объяснения 1
Uses crt; {модуль CRT, для красоты}
var x,y:integer; {описание переменных}
begin
write('Введи трехзначное число:'); {вывод текста на экран}
readln(x); {Чтение данных}
write('Введи любую цифру:'); {Вывод текста на экран}
readln(y); { Чтение данных }
if (x999) or (y9) {проверка условий}
then writeln('ERROR!') {Вывод текста, если условие соблюдено}
else {Вариант, если в начале все числа введено верно}
if (y=x div 100) or (y=x mod 10) or (y=x mod 100 div 10) then
writeln ('Цифра присутствует') {Вывод текста, если условие соблюдено}
else writeln ('Такой цифры нет'); { Вывод текста, если условие не соблюдено }
end.
- 22.11.2017 13:03
- thumb_up 51
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.