Вопрос по информатике:
Составить программу,
которая проверяла бы, не приводит ли суммирование двух целых чисел А и В к
переполнению (т.е. к результату большему чем 32 767). Если будет переполнение,
то сообщить об этом, иначе вывести сумму этих чисел.
- 07.12.2017 04:47
- Информатика
- remove_red_eye 5038
- thumb_up 47
Ответы и объяснения 2
Var
a, b, s : Integer;
begin
Write('введите a= ');
readln(a);
Write('введите b= ');
readln(b);
S:=a+b;
if s<32767 then writeln(s) else writeln('произошло переполнение');
end.
- 08.12.2017 22:08
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.