Вопрос по информатике:
Напишите пожалуйста, как написать во FREE PASCAL число в степени i+1. Вот сама программа:
Program zadacha;
Var k,s : Double;
n,i : LongInt;
Begin
k:=0
ReadLn(n);
s:=-1;
For i:=1 to n do
k:=k+exp((i+1)*Ln(s));
WriteLn(k:0:6);
ReadLn;
End.
Вот условие задачи:
Дано натуральное число n. Найдите сумму 1−1/2+1/3−...+(−1)n+1/n.
Формат входных данных:
Вводится целое число n(1≤n≤100000).
Формат выходных данных:
Требуется вывести одно число — значение выражения c точностью до шестого знака после запятой.
Примечания:
Условный оператор и оператор возведения в степень использовать запрещается.
- 02.09.2018 02:52
- Информатика
- remove_red_eye 10234
- thumb_up 76
Ответы и объяснения 1
У вас программа считает не формулу, приведенную в условии.
Если делать по условию, то:
s := 0;
i := 1; while (i <= n) do begin s := s + 1/n; inc(n,2); end;
i := 2; while (i <= n) do begin s := s - 1/n; inc(n,2); end;
- 03.09.2018 15:08
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.