Вопрос по информатике:
Вы ввели трехзначное число. Затем ввели любую цифру. Составьте программу, определяющую, есть ли в этом числе данная цифра.
- 25.02.2017 19:04
- Информатика
- remove_red_eye 3414
- thumb_up 69
Ответы и объяснения 1
Pascal:
var n,m:longint;
f:boolean;
begin
write ('Decimal: ');
readln(n);
write ('Number: ');
readln (m);
f:=true;
while (n0) do
begin
if ((n mod 10)=m) then
begin
f:=true;
break;
end;
n:=n div 10;
end;
if f then writeln ('YES!') else writeln ('NO');
readln;
end.
C++:
#include
using namespace std;
int main()
{
int n,m;
bool f = false;
cout <<"Decimal: ;br /> cin >>
- 26.02.2017 08:27
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.