Вопрос по информатике:
Составить программу вычисления суммы всех натуральных чисел меньше 100 и кратных b ( от1 до 100).
Нужно составить 1- с циклом с пред условием, 2 - с циклом с пост условием
- 21.09.2018 21:52
- Информатика
- remove_red_eye 17014
- thumb_up 100
Ответы и объяснения 1
1)
var sum:integer;
a,b:integer;
begin
a:=1;
readln(b);
for a:=1 to 99 do begin
if a mod b = 0 then
sum:=sum+a;
end;
writeln(sum);
end.
2)
var sum:integer;
a,b:integer;
begin
a:=1;
readln(b);
repeat
if a mod b = 0 then
sum:=sum+a;
inc(a);
until a=100
writeln(sum);
end.
- 23.09.2018 03:36
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.