Вопрос по информатике:
Цикл с параметром.Pascale.Нужно написать программу.
Определить количество чисел, кратных 5, среди N чисел, заданных случайным образом в диапозоне от -50 до 50.
- 20.06.2018 01:28
- Информатика
- remove_red_eye 6515
- thumb_up 77
Ответы и объяснения 1
Const nmax = 30;
var a:array [1..nmax] of integer;
i,k,n:integer;
begin
randomize;
k:=0;
repeat
write ('N = ');
readln (n);
until n in [1..nmax];
for i:=1 to n do
begin
a[i]:=random(101)-50;
writeln (a[i]);
if a[i] mod 5 = 0 then inc(k);
end;
writeln ('Kol-vo: ',k);
end.
- 21.06.2018 01:25
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.