Вопрос по информатике:
Написать программу в Free Pascal:
Дано целое число неизвестной размерности. Найти сумму цифр его составляющих.
- 25.07.2018 13:18
- Информатика
- remove_red_eye 10603
- thumb_up 67
Ответы и объяснения 1
Var n,sum:integer;
begin
sum:=0;
write ('N = ');
readln (n);
while n 0 do
begin
sum:=sum+n mod 10;
n:=n div 10;
end;
writeln ('Summa: ',sum);
end.
- 26.07.2018 04:14
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.