Вопрос по информатике:
"Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, оканчивающихся на 2. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 2. Программа должна вывести одно число – сумму чисел, оканчивающееся на 2. "
- 10.07.2018 13:38
- Информатика
- remove_red_eye 11714
- thumb_up 62
Ответы и объяснения 1
Program Test;
var i, amountOfNumbers, sum, number: integer;
begin
write('Введите количество чисел: ');
readln(amountOfNumbers);
writeln('Введите числа:');
sum := 0;
for i := 0 to amountOfNumbers - 1 do
begin
read(number);
if number mod 10 = 2 then
sum := sum + number;
end;
writeln('Сумма: ', sum);
end.
- 10.07.2018 22:48
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.