Вопрос по информатике:
Написать программу на паскале. Создать двухмерный массив из целых чисел, в котором поменять местами максимальный и минимальный элементы. Помогите пж.
- 08.11.2017 03:08
- Информатика
- remove_red_eye 16988
- thumb_up 49
Ответы и объяснения 1
Const NN=50;
Var
a:array [1..NN,1..NN] of integer;
maxi,maxj,mini,minj,i,j,n,m:integer;
begin
writeln('Введите кол-во строк и столбцов массива: ');
readln(n,m);
for i:= 1 to n do
for j:= 1 to m do
begin
write('a[',i,',',j,']= ');
readln(a[i,j]);
end;
writeln; writeln('Получившийся массив: ');
for i:= 1 to n do
begin
for j:= 1 to m do
write(a[i,j]:4);
writeln;
end;
maxi:=1;
maxj:=1;
mini:=1;
minj:=1;
for i:= 1 to n do
for j:= 1 to m do
begin
if a[i,j]>a[maxi,maxj] then
begin
maxi:=i;
maxj:=j;
end
else if a[i,j] begin
mini:=i;
minj:=j;
end;
end;
writeln; writeln('Получившийся массив: ');
i:=a[maxi,maxj];
a[maxi,maxj]:=a[mini,minj];
a[mini,minj]:=i;
for i:= 1 to n do
begin
for j:= 1 to m do
write(a[i,j]:4);
writeln;
end;
end.
- 09.11.2017 00:57
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.