Вопрос по информатике:
напишите программу, которая выводит на экран значение n! включая следующую функцию function factorial (n:integer):integer; var p,i:integer; begin p:=1; for i:=1 to n do p:=p*i; factorial:=p; end;
- 15.04.2018 01:47
- Информатика
- remove_red_eye 6201
- thumb_up 76
Ответы и объяснения 1
Var n:integer;
ch:char;
function factorial (n:integer):longint;
var p,i:integer;
begin
p:=1;
for i:=1 to n do p:=p*i;
factorial:=p;
end;
begin
write ('N = ');
readln (n);
writeln ('Factorial: ',factorial(n));
readln;
end.
- 16.04.2018 11:08
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.