Вопрос по информатике:
Напишите программу,которая анализирует человека по возрасту и относит к одной из пяти групп:дошкольник,школьник,студент,работник,пенсионер.Возраст вводится с клавиатуры.Используйте оператор CASE.
- 16.03.2018 01:13
- Информатика
- remove_red_eye 13095
- thumb_up 41
Ответы и объяснения 2
var
n:byte;
begin
write ('Vozrast: ');
readln(n);
case n of
1..6:writeln ('Дошкольник');
7..18:writeln ('Школьник');
19..24:writeln ('Студент');
25..55:writeln ('Работник');
56..110:writeln ('Пенсионер');
else writeln ('Не факт,что доживет');
end;
readln;
end.
- 17.03.2018 13:42
- thumb_up 44
Пишем и объяснем. Элемент case - это оператор аналогичный if, только условия более "скомпованы". Для того, чтобы не вводить 10 раз if используют case. Разбираем.
Uses crt;/p>
Var n:rea
- 18.03.2018 10:52
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.