Вопрос по информатике:
Написать программу на языке Паскаль. Вводятся размер и элементы одномерного массива A(N), состоящего из целых чисел. Подсчитать сумму простых чисел, оканчивающихся на 3. Результат вывести на экран.
- 13.06.2016 12:09
- Информатика
- remove_red_eye 5593
- thumb_up 11
Ответы и объяснения 1
uses crt;
Var a:array [1..100] of integer; i,n,s: integer;
Begin
Writeln('Введите размер массива'); readln(n);
For i:=1 to n do begin
writeln('Введите элемент массива номер ',i); read(a[i]);
end;
For i:=1 to n do
if a[i] mod 10=3 then s:=s+a[i];
Writeln('Сумма = ',s);
end.
Написано через PascalABC. Если используете другой паскаль вместо первой строчки пишите "Program 123;""
- 14.06.2016 00:23
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.