Вопрос по информатике:
Написать программу которая проверяет находится ли в массиве введенное с клавиатуры число. массив должен вводиться случайным образом(pascal)
- 25.04.2018 12:11
- Информатика
- remove_red_eye 3192
- thumb_up 49
Ответы и объяснения 2
В массиве n элементов.
Случайным образом вводятся целые числа от 0 до 999.
x - ведённое с клавиатуры число.
i - цикловая переменная.
var
a : array [1..100] of integer;
x, i, n : integer;
begin
readln (n);
for i := 1 to n do
a [ i ] := random (1000);
readln (x);
for i := 1 to n do
if a [ i ] := x then
writeln ('введённое с клавиатуры число находится в массиве');
end.
Если количество элементов в массиве известно изначально, например 25, тогда строку " readln (n);"" убираете, а строки
"" for i := 1 to n do ""
заменяете на
"" for i := 1 to 25 do ""
Минус данной программы: если введённое с клавиатуры число не находится в массиве, то программа ничего не выводит.
- 26.04.2018 21:18
- thumb_up 18
var
a:array [1..100] of integer;
i,n,k:integer;
f:boolean;
begin
write ('Razmer massiva (N<100): ');readln(n);
for i:=1 to n do begin
a[i]:=random(36)-10;
write (a[i],' ');
end;
writeln;
write ('Number: ');readln(k);
f:=false;
for i:=1 to n do
if a[i]=k then f:=true;
writeln (f);
readln;
end.
Выводит FALSE, если в масиве нет числа,иначе выводит TRUE.
- 27.04.2018 10:46
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.