Вопрос по информатике:
Написать программу, которая решает уравнение ax + b < 0 относительно x для любых чисел a и b, введёных с клавиатуры.
- 04.07.2018 04:11
- Информатика
- remove_red_eye 19784
- thumb_up 75
Ответы и объяснения 1
ax + b < 0
ax < -b
x < - b / a
Целые числа.
Язык программирования: Паскаль
var
a, b : integer;
begin
readln (a);
readln (b);
if (a = 0) and (b < 0) then
writeln ('x - любое число');
if (a = 0) and (b >= 0) then
writeln ('нет решений');
if a 0 then
writeln ('x < ', - b / a)
end.
- 05.07.2018 17:28
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.