Вопрос по информатике:
Написать программу, которая решает уравнение ax+b <0 относительно x для любых чисел a и b , введёных с клавиатуры.
Помогите пожалуйста)
- 23.09.2017 03:36
- Информатика
- remove_red_eye 15377
- thumb_up 95
Ответы и объяснения 2
ax + b < 0
ax < -b
x < - b / a
a, b могут быть дробными числами.
Язык программирования: Паскаль
var
a, b : real;
begin
readln (a);
readln (b);
if a 0 then
writeln ('x < ', - b / a);
if (a = 0) and (b < 0) then
writeln ('x - любое число');
if (a = 0) and (b >= 0) then
writeln ('нет решений')
end.
- 24.09.2017 02:10
- thumb_up 38
var
a,b,x:real;
begin
write ('A = ');readln(a);
write ('B = ');readln(b);
if (a=0) and (b>=0) then writeln ('Нет решений') else
if (a=0) and (b<0) then writeln ('X - любое число') else
if a>0 then writeln ('X < ',-b/a:0:4) else
if a ',-b/a:0:4);
readln;
end.
- 25.09.2017 14:47
- thumb_up 53
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.