Вопрос по информатике:
Написать программу, которая подсчитывает количество четных индексов положительных элементов введенного с клавиатуры массива целых чисел.
- 26.11.2017 11:06
- Информатика
- remove_red_eye 7282
- thumb_up 100
Ответы и объяснения 2
var
a:array [1..100] of integer;
i,n,k:integer;
begin
write ('Razmer massiva: ');readln(n);
k:=0;
for i:=1 to n do begin
write ('A[',i,'] = ');readln(a[i]);
if (a[i]>0) and (i mod 2 = 0) then k:=k+1;
end;
writeln ('Kol-vo: ',k);
readln;
end.
- 27.11.2017 17:25
- thumb_up 41
a - массив из n элементов
k - количество четных индексов положительных элементов
i - цикловая переменная, также индекс элемента массива
Язык программирования: Паскаль
var
a : array [1..100] of integer;
n, k, i : integer;
begin
k := 0;
readln (n);
for i:=1 to n do
begin
readln (a [ i ]);
if (i mod 2 = 0) and (a [ i ] > 0) then
k := k + 1;
end;
writeln (k);
end.
- 28.11.2017 00:40
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.