Вопрос по информатике:
Помогите написать программу в паскале. За ранее спасибо. Задача на одномерный массив.
Задание 3. Даны два массива A и B, состоящих из одинакового числа элементов. Найти среднее арифметическое элементов каждогомассива и сравнить эти значения. Заполнение массива выберите по своему усмотрению.
- 23.02.2015 02:21
- Информатика
- remove_red_eye 13032
- thumb_up 51
Ответы и объяснения 2
var
a,b:array [1..10] of integer;
i:integer;
s1,s2:real;
begin
randomize;
for i:=1 to 10 do begin
a[i]:=random(12)-1;
s1:=s1+a[i];
b[i]:=random(9)+1;
s2:=s2+b[i];
write (a[i],' ');
end;
writeln;
for i:=1 to 10 do write (b[i],' ');
writeln;
s1:=s1/10;
s2:=s2/10;
writeln ('S1 = ',s1);
writeln ('S2 = ',s2);
if s1>s2 then writeln ('S1>S2') else
if s1 readln; end.
- 24.02.2015 07:26
- thumb_up 49
uses crt;
var
a,b:array [1..100] of integer;
i,k:integer;
Sa,Sb:real;
begin
write('Введите количество элементов массивов: '); read(k);
clrscr;
randomize;
writeln('Массив А:');
for i:=1 to k do
begin
a[i]:=random(50)-25;
b[i]:=random(100)-50;
Sa:=Sa+b[i];
Sb:=Sb+a[i];
write (a[i]:4);
end;
writeln; writeln('Массив В:');
for i:=1 to k do
write (b[i]:4);
writeln;
Sa:=Sa/k; Sb:=Sb/k;
writeln ('Сумма элементов массива А: ',Sa);
writeln ('Сумма элементов массива В: ',Sb);
if Sa>Sb then writeln ('Ср.(А)>Ср.(В)')
else
if Sa
end.
- 25.02.2015 20:56
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.