Вопрос по информатике:
В массиве из 10 вещественных чисел вычислить среднее арифметическое массива, стоящих левее максимального. Составить программу на языке паскаль. Пожалуйста очень надо.
- 02.02.2018 11:35
- Информатика
- remove_red_eye 19703
- thumb_up 42
Ответы и объяснения 1
uses crt;
var
a:array [1..10] of integer;
i,max,k,n:integer; sr:real;
begin
clrscr; randomize;
writeln('Массив:');
for i:=1 to 10 do
begin
a[i]:=random(100);
write(a[i],' ');
end;
writeln;
max:=a[1];
for i:=1 to 10 do
if a[i]>max then
begin
max:=a[i];
n:=i;
end;
writeln('Максимальный элемент массива: ',max);
for n:=n+1 to 10 do
begin
sr:=sr+a[n];
k:=k+1;
end;
write('Среднее чисел, стоящих левее максимального: ',(sr/k));
end.
- 03.02.2018 19:02
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.