Вопрос по информатике:
Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h. Результат представить в виде таблицы, первый столбец которой — значения аргумента, вто¬рой — соответствующие значения функции: F(x)=xcos(1\x)+2 Решить нужно в паскаль.
- 25.09.2018 05:08
- Информатика
- remove_red_eye 18855
- thumb_up 135
Ответы и объяснения 1
uses crt;
var a,b,h: real;
function f(x: real): real;
begin
f:=x*cos(1/x)+2;
end;
begin
write('a: ');
read(a);
write('b: ');
read(b);
write('h: ');
read(h);
writeln('Полученный результат:');
writeln(' x | f(x) ');
while a begin
writeln(a:5:4,'|',f(a):5:4);
a:=a+h;
end;
end.
- 25.09.2018 21:23
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.