Вопрос по информатике:
Гнездо для ножки деревянной кровати имеет форму прямоугольной вырезки. Определить, подойдет ли данный четырехугольный брусок для этого гнезда.
- 14.10.2017 19:59
- Информатика
- remove_red_eye 18267
- thumb_up 44
Ответы и объяснения 2
Если для этого нужно написать программу, то смотри(Паскаль):
uses crt;
var a,b,c,d,p,p1:real;
begin
clrscr;
write('длина вырезки ');read(a);
write('ширина вырезки ');read(b);
p:=2*(a+b);
write('длина сечения бруска ');read(c);
write('ширина сечения бруска ');read(d);
p1:=2*(c+d);
writeln;
if (p=p1) then
begin
if (c=a) or (c=b) then write('подойдет')
else write('не подойдет');
end
else write('не подойдет');
end.
- 15.10.2017 12:57
- thumb_up 13
Program DenisDen4ik;
uses crt;
var
a1,a2,b1,b2:real;
begin
writeln('Введите размеры вырезки ');
write('ширина ');read(a1);
write('длина ');read(a2);
writeln('Введите размеры сечения бруска ');
write('ширина ');read(b1);
write('длина ');read(b2);
writeln();
if ((a1=b1) and (a2=b2)) or ((a1=b2) and (a2=b1)) then
writeln('Этот брусок подойдет')
else writeln('Этот брусок не подойдет');
end.
- 16.10.2017 02:38
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.