Вопрос по информатике:
Дан одномерный массив состоящий из 10 элементов.Найти произведение этих 10 элементов(составить программу на языке паскаль). ПОМОГИТЕ ПОЖАЛУЙСТА:*****
- 24.01.2017 17:50
- Информатика
- remove_red_eye 12226
- thumb_up 104
Ответы и объяснения 2
uses crt;
var a:array [1..10] of real;
i:integer; p:real;
begin
clrscr;
randomize;
p:=1;
for i:=1 to 10 do
begin
a[i]:=random(100)-50;
write(a[i],' ');
p:=p*a[i];
end;
writeln;
write('proizvedenie: ',p);
end.
- 24.01.2017 23:22
- thumb_up 74
Program Please;
uses crt;
const n=10;
var
a:array[1..n] of integer;
i:integer;
mm:real;
begin
writeln('*** alphaues is thinking... ***');
writeln('*** OK ***');
writeln();
writeln('Элементы массива:');
{создание и вывод массива}
mm:=1;
for i:=1 to n do
begin
a[i]:=random(100)-50;
write (a[i]:5);
mm:=mm*a[i];
end;
writeln();
writeln();
writeln('Произведение элементов массива ',mm);
end.
- 26.01.2017 15:28
- thumb_up 51
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.