Вопрос по информатике:
Написать программу, которая генерирует 10 случайных чисел в диапозоне от 1 до 10, выводит эти числа на экран и вычисляет их среднее арифметическое
- 09.10.2017 19:28
- Информатика
- remove_red_eye 5500
- thumb_up 77
Ответы и объяснения 2
PROGRAM ThreeSequences(INPUT, OUTPUT);
VAR
Number: ARRAY[1 .. 3, 1 .. 10] OF INTEGER;
ArithmeticAverage: ARRAY[1 .. 3] OF INTEGER;
I, J: INTEGER;
BEGIN {ThreeSequences}
Randomize;
{Генерирует 3 последовательности по 10 случайных чисел}
FOR I := 1 TO 3
DO
FOR J := 1 TO 10
DO
Number[I][J] := Random(10) + 1;
{Выводит последовательности и считает среднее арифметическое}
FOR I := 1 TO 3
DO
BEGIN
WRITE('Sequences: ');
ArithmeticAverage[I] := 0;
FOR J := 1 TO 10
DO
BEGIN
WRITE(Number[I][J]:3);
{Складывает все числа последовательности}
ArithmeticAverage[I] := ArithmeticAverage[I] + Number[I][J];
END;
WRITELN;
{Делит на количество чисел последовательности}
ArithmeticAverage[I] := ArithmeticAverage[I] DIV J;
WRITELN('ArithmeticAverage: ', ArithmeticAverage[I]);
END;
END. {ThreeSequences}
- 09.10.2017 22:43
- thumb_up 17
uses crt;
var
a,k,s:shortint;
sr:real;
begin
clrscr;
randomize;
repeat
a:=random(10)+1;
write (a:3);
k:=k+1;
s:=s+a;
until k=10;
sr:=s/k;
writeln;
writeln ('Srednee: ',sr:0:4);
readln;
end.
;- 09.10.2017 22:39
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.