Вопрос по информатике:
Написать программу, составить алгоритм заполнения массива десятью случайными целыми числами, каждое их которых лежит в пределах до 200. Найти максимальное и минимальное из этих чисел, а также позиции, в которых они расположены. Массив вывести на экран. Заранее спасибо!
- 11.03.2017 10:37
- Информатика
- remove_red_eye 14260
- thumb_up 94
Ответы и объяснения 1
clrscr;
randomize;
for i:=1 to 10 do
begin
a[i]:=random(201);
write(a[i],' ');
end;
max:=a[1]; min:=a[1];
for i:=1 to 10 do
begin
if a[i]>max then
begin
max:=a[i]; m:=i;
end;
if a[i]
min:=a[i]; n:=i;
end;
end;
writeln;
writeln('max=',max,'(nomer ',m,');');
writeln('min=',min,'(nomer ',n,');');
end.
- 11.03.2017 22:55
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.