Вопрос по информатике:
Напишите программу для решения следующей задачи . Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо нее автомобилей, округляя значения скорости до целых чисел. Необходимо определить максимальную зарегистрированную скорость автомобиля. Если скорость хотя бы одного автомобиля была меньше 30 км/ч, выведи YES, иначе выведите NO. Программа получает на вход число проехавших автомобилей N ( 1 ≤ N ≤ 30), затем указываются их скорости. Значение скорости не может быть меньше 1 и больше 300. Программа должна сначала вывести максимальную скорость, затем YES или NO.
- 01.06.2018 18:35
- Информатика
- remove_red_eye 10864
- thumb_up 92
Ответы и объяснения 1
Program N198453627;
uses crt;
var
n,i:integer;
max,v:real;
yes: string;
begin
writeln('*** alphaues is thinking... ***');
writeln('*** OK ***');
max:=0;
yes:='NO';
writeln('Введите количество машин (не больше 30 - у меня мало памяти!)');
write('N = ');
readln(n);
if n>30 then
writeln('Это слишком много!')
else
begin
writeln('Вводите зарегистрированную скорость каждого автомобиля');
for i:=1 to n do
begin
write(i,'-й автомобиль: ');
readln (v);
if v >300 then
begin
writeln ('По-моему, твои приборы плохо отрегулированы - так быстро машины не ездят!');
writeln ('Это число не будет учтено');
end
else
if v < 1 then
begin
writeln ('Ты точно умеешь измерять скорость автомобиля? Скорость не может быть меньше 1!');
writeln ('Это число не будет учтено');
end
else
begin
if v<30 then yes:='YES';
if v>max then max:=v;
end;
end;
writeln();
writeln('Максимальная зарегистрированная скорость: ',max);
writeln('Cкорость меньше 30 км/ч? ',yes);
end;
end.
- 02.06.2018 17:00
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.