Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 5.
- 14.01.2018 07:16
- Информатика
- remove_red_eye 3501
- thumb_up 71
Ответы и объяснения 2
program name;
uses crt;
var i,s,n:integer;
a: array [1..100] of integer;
begin
clrscr;
readln(n);
s:=0;
for i:=1 to n do begin
if a[i] mod 5= 0 then begin
s:=s+a[i];
end;
end;
writeln(s);
end.
- 14.01.2018 21:03
- thumb_up 26
CLS
a:
INPUT n
IF n < 1 OR INT(n) n OR n > 100 THEN GOTO a
DIM a(n)
FOR i = 1 TO n
b:
INPUT a(n)
IF a(n) < 1 OR INT(a(n)) a(n) OR a(n) > 300 THEN GOTO b
IF INT (a(n) / 5) = a(n) / 5 THEN s = s + a(n)
NEXT i
PRINT s
END
- 16.01.2018 03:49
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.