Вопрос по информатике:
Написать алгоритм и составить программу для вычисления суммы квадратов первых N членов натурального ряда.
- 13.05.2018 21:56
- Информатика
- remove_red_eye 7348
- thumb_up 33
Ответы и объяснения 1
Программа получает на вход N, почле чего в цикле постепенно обрабатывает все натуральные числа от 1 до N включительно и в ячейку памяти s откладывает их квадраты.
program summa;
uses crt;
var N,a,s,i: integer;
begin
read(N); a:=0; s:=0;
for i:=1 to N do
begin
a:=a+1;
s:=s+(a*a);
end;
writeln(s);
end.
- 14.05.2018 04:07
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.