Вопрос по информатике:
1. PASCAL. Даны три точки A(x1,y1), B(x2,y2), C(x3,y3). Написать программу, определяющую, которая из точек находится ближе к началу координат.
- 03.03.2018 22:11
- Информатика
- remove_red_eye 4028
- thumb_up 105
Ответы и объяснения 1
Проверено - работает на Паскаль АВС:
Program kovyarovsany;
var
x1,y1,x2,y2,x3,y3:integer;
d1,d2,d3:real;
begin
write ('X1 = ');readln(x1);
write ('Y1 = ');readln(y1);
write ('X2 = ');readln(x2);
write ('Y2 = ');readln(y2);
write ('X3 = ');readln(x3);
write ('Y3 = ');readln(y3);
d1:=sqrt(x1*x1+y1*y1);
d2:=sqrt(x2*x2+y2*y2);
d3:=sqrt(x3*x3+y3*y3);
if (d1=d2) and (d1=d3) then
writeln ('Все три точки на одинаковом расстоянии от начала координат ')
else
if (d1=d2) and (d1
else
if (d2=d3) and (d2
else
if (d1=d3) and (d1
else
if (d1
else
if (d2
else
writeln ('Точка 3 ближе всех');
end.
- 04.03.2018 22:28
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.