Вопрос по информатике:
Напишите программу, которая в последовательности натуральных
чисел определяет максимальное число, кратное 5. Программа
получает на вход количество чисел в последовательности, а затем сами
числа. В последовательности всегда имеется число, кратное 5.
Количество чисел не превышает 1000. Введённые числа не превышают
30 000.
Программа должна вывести одно число – максимальное число, кратное 5.
- 01.02.2018 01:35
- Информатика
- remove_red_eye 7286
- thumb_up 69
Ответы и объяснения 2
#include
using namespace std;
int main()
{
int n;
int a;
int max = 0;
cin>>n;
for(int i=0;i { cin>>a; if(a%5==0 && a>max) max = a; } cout< system("PAUSE");/p> }
- 02.02.2018 17:02
- thumb_up 48
Program Fanisca;
uses crt;
var
n,temp,i,max: integer;
begin
write('Введите число N=');
readln(n);
max:=0;
i:=1;
writeln('*** alphaues is thinking... ***');
while i<=n do
begin
write('Введите ',i,'-е число ');
readln(temp);
if (max
end;
writeln('Максимальное число, кратное 5, равно ',max);
end.
- 02.02.2018 22:15
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.