Вопрос по информатике:
Даны натуральное число n и последовательность целых чисел а1, а2,…,аn..Все положительные элементы уменьшить в 2 раза. Составить блок-схему алгоритма, написать программу
- 11.12.2016 04:40
- Информатика
- remove_red_eye 18120
- thumb_up 79
Ответы и объяснения 2
var a:array [1..1000] of real;
i,n:integer;
begin
readln(n);
for i:=1 to n do
if a[i]>0 then a[i]:=a[i]/2;
for i:=1 to n do
writeln(a[i]);
end.
- 12.12.2016 19:42
- thumb_up 56
Program svwnx90f;
uses crt;
const n = 100;
var
A:array [1..n] of real;
i,j:integer;
begin
writeln('*** alphaues is thinking... ***');
writeln('*** OK ***');
Randomize;
{ввод чисел}
for i:=0 to 9 do
for j:=1 to 10 do
begin
A[i*10+j]:= Random(101)-50;
write(A[i*10+j]:7:1,' ');
end;
writeln;
writeln('Положительные элементы уменьшаются в 2 раза... ');
writeln('Результат:');
for i:=0 to 9 do
begin
for j:=1 to 10 do
begin
if A[i*10+j]>0 then A[i*10+j]:= A[i*10+j]/2;
write(A[i*10+j]:7:1,' ');
end;
end;
end.
- 13.12.2016 20:36
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.