Вопрос по информатике:
даны 10 произвольных действительных числа(вводятся с клавиатуры).Подсчитать количество отрицательных чисел помогите составить программу
- 11.06.2018 13:45
- Информатика
- remove_red_eye 4712
- thumb_up 103
Ответы и объяснения 2
var a,s,i:integer;
begin
s:=0;
for i:=1 to 10 do
begin
write('Число: '); readln(a);
if a<0 then s:=s+1;
end;
writeln('Кол-во отрицательных чисел: ',s);
end.
- 12.06.2018 10:21
- thumb_up 18
Program Zorkini;
uses crt;
const n=10;
var
Z: real;
i,k: integer;
begin
k:=0;
for i:=1 to n do
begin
write('Введите ',i,'-e число ');
readln(z);
if z<0 then k:=k+1;
end;
writeln('Количество отрицательных чисел ',k);
end.
- 13.06.2018 07:24
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.