Вопрос по информатике:
Решить на C#, используя циклы.
Составить программу для вычисления и вывода n первых чисел Фибоначчи. Числа Фибоначчи получаются с помощью следующих рекуррентных соотношений где
- целое. Отследить корретность ввода исходных данных.
- 17.08.2018 17:09
- Информатика
- remove_red_eye 3628
- thumb_up 76
Ответы и объяснения 1
using System;
class Program
{
public static int Fibonacci(int n)
{
int a = 0;
int b = 1;
for (int i = 0; i < n; i++)
{
int temp = a;
a = b;
b = temp + b;
}
return a;
}
static void Main()
{
Console.Write("Введите N:");br /> int n = Int32.Parse(Console.ReadLine()
- 17.08.2018 21:18
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.