Вопрос по информатике:
СИ++ Составить программу, печатающую все простые числа из диапазона [2, n] при целом n > 2.
- 27.07.2018 20:52
- Информатика
- remove_red_eye 2813
- thumb_up 61
Ответы и объяснения 1
#include
using namespace std;
int isSimple (int x)
{
int retVal = 1;
int i = 2;
while (i<=sqrt((double)x) && retVal==1)
{
if (x%i==0) retVal=0;
i++;
}
return retVal;
}
void main(){
int n(0);
cout<>n;
if (n < 3)
cout<<"error;br /> else {
for (int i=
- 28.07.2018 14:18
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.