Вопрос по информатике:
Задача 1
Составить программу
При поступлении в вуз абитуриенты , получившие "двойку" на первом экзамене , ко второму не допускаются . В массиве A[n] записаны оценки экзаменующихся , полученные на первом экзамене . Подсчитать , сколько человек не допущено ко второму экзамену .
Задача 2
В одномерном массиве , состоящем из n вещественных элементов , вычислить ;/p>
1) минимальный элемент массив
- 13.03.2018 04:19
- Информатика
- remove_red_eye 3848
- thumb_up 40
Ответы и объяснения 1
Задача1
массив определи как array[];
чтобы посчитать, просто используй счетчик, но сначала инициализируй переменную, которая содержит ответ задачи:
int n;
array [n];
int answer;
for (i=0, i < n, i++)
{
if (array[i] == 2)
answer++;
}
std::cout< Как то так Задача2 array[n]; for (int i =1, i < n, i++) { if (array[0] >= array[i]) array[0] = array[i]; } std::cout << array[0]; //Это было решение первого пункта int first; int last bool positive; while (positive == false ) { for (int i = 0; i < n; i++) { if (array[i] > 0) { positive = true; first = i; array[i] = -1; } } while (positive == false ) { for (int i = 0, i < n, i++) { if (array[i] > 0) { positive = true; last = i; } } int summ for (int i = first, i < last, i++) { summ += array[i]; } std::cout< // ПРеобразую newarray [n]; int a = 0; for (int i = 0, i < n, i++) { if (array[i] == 0) { newarray[a] = array[i]; a++; } } for (int i = 0, i < n, i++) { if (array[i] != 0) { newarray[a] = array[i]; a++; } } std::cout<< newarray;
- 14.03.2018 16:21
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.