Вопрос по информатике:
Написать программу, запрашивающую с клавиатуры целые числа и определяю-щую максимальное и минимальное из них. Окончание ввода – число 0. Протестиро-вать программу для последовательности: -3 5 6 -11 24 -1 0.
ПАСКАЛЬ
- 04.01.2018 22:50
- Информатика
- remove_red_eye 11528
- thumb_up 106
Ответы и объяснения 1
uses crt;
var x,min,max:integer;
begin
clrscr; min:=0;max:=0;
Writeln('Write x = ');
readln(x);
min:=x;
max:=x;
while x0 do
begin
readln(x);
if ((min > x) and (x0)) then min:=x;
if ((max < x) and (x0)) then max:=x;
end;
writeln('max = ',max);
writeln('min = ',min);
readln
end.
- 06.01.2018 12:12
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.