Вопрос по информатике:
Вы приобрели котёнка. Каждый вечер вы определяете его вес с помощью весов.Как можно описать на Паскале массив, в котором будут храниться значения веса котёнка в течение месяца(например, мая)?
______________
пожалуйста,напишите программу попроще.
- 07.11.2017 12:12
- Информатика
- remove_red_eye 20804
- thumb_up 104
Ответы и объяснения 2
const n=31;
var a:array[1..n] of integer; // Массив до 31
i:integer;
begin
a[1]:=1; // Обьявляем значения
a[2]:=3; // Обьявляем значения
// итд до 31
for i:=1 to n do writeln(i,' day:=',a[i]); // Вывод массива
end.
- 08.11.2017 06:10
- thumb_up 34
Вообще-то описание массива содержится в строке
var mas:array[1..n] of integer;
А вся программа ввода иммет вид:
Program Cat;
const n=31;
var mas:array[1..n] of integer;
i:integer;
begin
for i:=1 to n do
begin
write('Введите вес котенка ',i,' -го мая');
readln(mas[i]);
end;
end.
- 09.11.2017 12:38
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.