Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет максимальное четное число. Программа получает на вход целые числа, количество введенных данных неизвестно, последовательность чисел заканчивается числом 0. На Паскале
- 01.04.2018 16:43
- Информатика
- remove_red_eye 5764
- thumb_up 91
Ответы и объяснения 1
var a,max:integer;
begin
max:=0;
a:=0;
read(a);
while a0 do
begin
if (a mod 2=0) and (a>=max) then max:=a;
read(a);
end;
write(max);
end.
- 02.04.2018 03:07
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.