Вопрос по информатике:
Вводится строка текста из N символов,слова разделены одним пробелом.Найти длину самого длинного слова.Написать программу в Паскале.
- 15.09.2018 21:13
- Информатика
- remove_red_eye 2659
- thumb_up 78
Ответы и объяснения 1
var
i,k,l:integer;
s:string;
begin
readln(s);
k:=0;
i:=1;
while i
l:=0;
while (s[i]' ') and (i
l:=l+1;
i:=i+1;
end;
i:=i+1;
if l>k then k:=l;
end;
writeln(k);
end.
- 17.09.2018 20:23
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.