Вопрос по информатике:
Дан целочисленный массив состоящий из элементов, элементы массива принимают значение от 0 до 100. Составьте программу для вычисления произведения элементов массива, которые не четны и делятся на 3.
- 14.10.2017 06:18
- Информатика
- remove_red_eye 12732
- thumb_up 42
Ответы и объяснения 1
const n=10;
var
a:array [1..n] of integer;
i,s:integer;
begin
Randomize;
for i:=1 to n do
begin
a[i]:=random(100);
write(a[i],' ');
end;
for i:=1 to n do if (a[i] mod 2 =1) and (a[i] mod 3 =0) then if s=0 then s:=a[i] else s:=s*a[i];
writeln;
writeln(s);
end.
- 15.10.2017 17:01
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.