Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет сумму двухзначных чисел, кратных 5. Программа получает на вход натуральные числа, количество введенных чисел не известно, последовательность чисел заканчивается 0.
Количество чисел не превышает 100. Введенные числа не превышают 30000.
Программа должна вывести одно число: сумму двухзначных чисел, кратных 5.
Люди! Плиииз, помогите! Т,Т
- 01.08.2018 19:42
- Информатика
- remove_red_eye 10706
- thumb_up 83
Ответы и объяснения 1
program qf;
uses crt;
var x,y,s:integer;
begin
clrscr;
writeln('введи число');
readln(x);
s:=0;
while x0 do begin
if (x>9)and(x<100)and(x mod 10=5) then
s:=s+x;
writeln('введи новое число');
readln(x);
end;
writeln('сумма дувхзначных чисел=',s);
readln;
end.
- 02.08.2018 12:04
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.