Вопрос по информатике:
Составить программу, которая каждое введенное положительное число увеличивает в два раза, а отрицательное возводит в квадрат.
- 13.07.2018 08:28
- Информатика
- remove_red_eye 5831
- thumb_up 41
Ответы и объяснения 2
Pascal ABC
var a : integer;
begin
readln(a);
If a >= 0 then a := 2*a;
If a < 0 then a := a*a;
writeln(a)
end.
- 14.07.2018 12:32
- thumb_up 50
program z1;
uses crt;
var x,y:integer;
begin
clrscr;
writeln('введи число');
readln(x);
if x>=0 then x:=x*2
else
if x<0 then sqr(x);
writeln(x);
readln;
end.
- 15.07.2018 08:49
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.