Вопрос по информатике:
Напишите программу, которая в последовательности целых чисел находит сумму четных чисел в диапазоне от 5 до 25. Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30000. Программа должна вывести одно число: сумму четных чисел в диапазоне от 5 до 25. Входные данные : 4, 16, 17, 26,0 Выходные данные: 16
- 01.10.2015 11:11
- Информатика
- remove_red_eye 9990
- thumb_up 48
Ответы и объяснения 1
Program Summa;
Uses Crt;
var s,n,c:integer;
begin
clrscr;
write('Введите числа коннц ввода 0: ');
s:=0;c:=0;
repeat
readln(n);
c:=c+1;
if (n mod 2)=0 then
if ((n>=5)and (n<=25)) then s:=s+n;
until (n=0) or (c=1000) ;
write('Сумма ',c,' чётных чисел в диапазоне от 5 до 25:',s);
readkey;
end.
- 02.10.2015 19:53
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.