Вопрос по информатике:
СРОЧНО!!! ПРОГРАММА С ВЕТВЛЕНИЕМ!!! Составьте программу, которая по введенному вами k-число грибов, печатает фразу: "Мы нашли в лесу k грибов" причем согласовывает окончание слова «гриб» с k.!!!
- 20.05.2017 11:21
- Информатика
- remove_red_eye 7544
- thumb_up 100
Ответы и объяснения 2
var k:integer;
begin
writeln('Input number of mushrooms: ');
Readln(k);
if k=1 then Writeln('Mi nashli ',k,' grib')
else
if (k=2) or (k=3) or (k=4) then Writeln('Mi nashli ',k,' griba')
else
Writeln('Mi nashli ',k,' gribov');
readln;
end.
- 21.05.2017 09:11
- thumb_up 67
var
count:integer;
begin
write('Введите количество грибов '); readln(count);
write('Мы нашли в лесу ', count);
case count div 10 of
1: writeln(' грибов');
else
case count mod 10 of
0, 5..9: writeln(' грибов');
1: writeln(' гриб');
2..4: writeln(' гриба');
end;
end;
end.
- 22.05.2017 20:03
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.