Вопрос по информатике:
Линейный массив содержит сведения о количестве осадков, выпавших за каждый из 12 месяцев одного года. Составить программу, определяющую общее количество осадков за этот год, среднемесячное количество осадков, количество засушливых месяцев (когда количество осадков было меньше 30 мм), самый засушливый месяц года. для Turbo Pascal.
- 26.08.2018 20:28
- Информатика
- remove_red_eye 4358
- thumb_up 62
Ответы и объяснения 1
Program zadacha;
var
a: array [1..12] of integer;
i, o, k, z, j: integer;
s:real;
begin
writeln('vvedite kolichestvo osadkov');
for I:=1 to 12 do
read(a[I]);
o:=0;
for I:=1 to 12 do
o:=o+a[I];
writeln('obshee kolichestvo osadkov=',o);
s:=o/12;
writeln('srednee kolichestvo=',s:3:2);
k:=0;
for i:=1 to 12 do
if a[I]<30 then k:=k+1;
writeln('kolichestvo zasushlivih=',k);
j:=30;
for I:=1 to 12 do
if a[I] begin
j:=[I];
z:=I;
end;
writeln('samiy zasusliviy mesyac=',z);
readln;
end.
- 27.08.2018 17:28
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.