Вопрос по информатике:
написать программу на Паскале:
"если введенное целое число является трехзначным, то удалить из него среднюю цифру;если число двухзначное, то удвоить крайние цифр
- 19.09.2018 01:28
- Информатика
- remove_red_eye 2032
- thumb_up 81
Ответы и объяснения 1
program z1;
uses crt;
var n:integer;
begin
writeln(''вв число');
readln(n);
if n>999 then writeln('ошибка ввода') else
if n>100 then writeln((n div 100)*10+n mod 10 ) else
writeln((((n div 10)*2)*10)+((n mod 10)*2));
end.
- 20.09.2018 19:01
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.